Author Topic: Ass Subtitles not showing in Preview  (Read 933 times)

Picketlaw1

  • Newbie
  • *
  • Posts: 10
Ass Subtitles not showing in Preview
« on: July 09, 2018, 02:49:51 PM »
Hi, I'm totally new to Avidemux but find it incredibly useful. However I am currently having problems hardsubbing subtitles prepared in Aegisub and saved as an .ass file. My video (MP4) loads perfectly but when I try to add the .ass file the subtitles don't appear. I set the video output to Mpeg4 ASP(xvid4) and use the subtitle filter to add the .ass file using libass and nothing happens - the video just opens with no subtitles attached.
Please appreciate I am not a programmer - just an enthusiastic amateur! - so any SIMPLE suggestions would be appreciated.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6052
Re: Ass Subtitles not showing in Preview
« Reply #1 on: July 10, 2018, 06:32:53 AM »
OK, the subtitles should be showing in preview.

- Unpack TestAvidemux.ass.7z ( 7zipped format )
- Load a 720p video (1280 x 720 pixels)
- Open attached TestAvidemux.ass in subtitle filter
- Click OK
- This should be showing in Active Filters

SSA/ASS/SRT
 ASS/SSA Subtitles: TestAvidemux.ass

- Click [close]
- Click the Filter button (see underlined with red below)
- play video, subtitles should be showing

can you confirm this works?

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6052
Re: Ass Subtitles not showing in Preview
« Reply #2 on: July 10, 2018, 06:41:06 AM »
you should get a similar result to this:

subtitle test.mp4: 1 file, 52.6 MB in total ・ Will be deleted on 17 July, 2018
Download link https://we.tl/kudHnA18Lv

Picketlaw1

  • Newbie
  • *
  • Posts: 10
Re: Ass Subtitles not showing in Preview
« Reply #3 on: July 14, 2018, 04:55:14 PM »
Jan, Many thanks for the reply. Excuse my ignorance but please let me know where to locate TestAvidemux.ass.7z. I tried Googling but found nothing.

Picketlaw1

  • Newbie
  • *
  • Posts: 10
Re: Ass Subtitles not showing in Preview
« Reply #4 on: July 14, 2018, 05:05:28 PM »
Jan, no need to reply - just noticed your attachments!! Sorry.

Picketlaw1

  • Newbie
  • *
  • Posts: 10
Re: Ass Subtitles not showing in Preview
« Reply #5 on: July 14, 2018, 05:22:22 PM »
Jan, I tried what you suggested but the subtitles did not load onto my 720p video.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 2270
Re: Ass Subtitles not showing in Preview
« Reply #6 on: July 14, 2018, 10:14:23 PM »
IMHO, the first thing to try should be clearing the fontconfig cache. Anyway, this looks like a font issue for me.

Picketlaw1

  • Newbie
  • *
  • Posts: 10
Re: Ass Subtitles not showing in Preview
« Reply #7 on: July 16, 2018, 02:30:02 PM »
Eumagga0x2a, how do I clear the fontconfig cache?

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 2270
Re: Ass Subtitles not showing in Preview
« Reply #8 on: July 16, 2018, 02:36:22 PM »
Delete (or rename) the folder which contains the cache. Unsure about the exact location, it could be

%localappdata%\fontconfig\cache

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6052
Re: Ass Subtitles not showing in Preview
« Reply #9 on: July 17, 2018, 06:35:15 AM »
You don't have other settings in Active Filters: SSA/ASS/SRT for:
- Line spacing
- Font scale
- Top margin
- Bottom margin
« Last Edit: July 17, 2018, 06:36:46 AM by Jan Gruuthuse »

Picketlaw1

  • Newbie
  • *
  • Posts: 10
Re: Ass Subtitles not showing in Preview
« Reply #10 on: July 23, 2018, 11:14:10 AM »
Jan, These settings are in Active Filters for SSA/SSA/SRT but I have never used them since I thought they would affect the position of all the subtitles, which is not what I want. eumagga0x2a, I couldn't locate the cache you described.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 2270
Re: Ass Subtitles not showing in Preview
« Reply #11 on: July 23, 2018, 03:32:43 PM »
Could you please load a video with dimensions 1280x720, set encoding mode (not copy) for video, add the subtitle filter, load the test .ass file provided by Jan, enable filter preview in the main window, play the video, then compress and attach the admlog.txt from %localappdata%\avidemux to your reply.

Maybe something is logged from the internal libass which could shed some light on the nature of the problem. Otherwise I could only suspect that something is wrong with fonts installed on your system. Does The GIMP, especially the text tool, work fine?

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6052
Re: Ass Subtitles not showing in Preview
« Reply #12 on: July 24, 2018, 05:17:54 AM »
Do test as proposed by eumagga0x2a.
Could you please load a video with dimensions 1280x720, set encoding mode (not copy) for video, add the subtitle filter, load the test .ass file provided by Jan, enable filter preview in the main window, play the video, then compress and attach the admlog.txt from %localappdata%\avidemux to your reply.

Then if on Windows 10Q: How to reset Font settings in Windows 10

Picketlaw1

  • Newbie
  • *
  • Posts: 10
Re: Ass Subtitles not showing in Preview
« Reply #13 on: July 24, 2018, 11:19:21 AM »
Firstly, many thanks for all your help! I hope I have followed your instructions correctly and attach the admin log file as requested. I'm having file size problems with the video but I'll persevere! What is GIMP and how can I check it is working correctly? I'll also attempt to reset the font settings.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 2270
Re: Ass Subtitles not showing in Preview
« Reply #14 on: July 24, 2018, 12:08:01 PM »
Quote
Code: [Select]
Fontconfig error: Cannot load default config file
[ass] No usable fontconfig configuration file found, using fallback.
Fontconfig error: Cannot load default config file
[ass] Added subtitle file: 'C:/Users/Stewart/Downloads/New folder/TestAvidemux.ass' (3 styles, 11 events)

I looks like fontconfig doesn't find its configuration. Does the folder C:\Program Files\Avidemux 2.7 - 32 bits\etc\fonts with a "fonts.conf" file inside exist?

Quote
I'm having file size problems with the video

You are re-encoding a H.264 video (albeit likely created using the base profile as it doesn't contain B-frames) with a massively inferior Xvid codec. The resulting file has to be huge in comparison to the source in order to achieve a similar visual quality.