June 20, 2021, 12:22:31 AM



Drag and drop append appears to be broken.

Started by fish, January 20, 2019, 06:51:18 AM

Previous topic - Next topic


I forgot to publish checksums for the private build:

sha256sum avidemux_r190331-162845_win64Qt5.zip
e1433f11474570da0be391f70fe0f097020e225bdde019bc1a329b00381dea0b  avidemux_r190331-162845_win64Qt5.zip

md5sum avidemux_r190331-162845_win64Qt5.zip
a6bdadc149cda6728be655f26799c0a7  avidemux_r190331-162845_win64Qt5.zip

File size: 42772103 bytes.


Thank you, I will give this version a try. Something changed between v2.7.1 and v2.7.2 which is causing the problem. I first noticed when I tried one of the nightly versions that was current around the start of this thread, so between v2.71 and then.
I didn't update to version v2.7.3  because I didn't notice but I will update to that version now. I tend to stick with a version for a while, the reasoning  being that in frequent updates, eventually something may change that produces junk files. You then end up with a lot of defective files before realising and no way back. At least keeping the same version, I know what works and if I really need an update then I will. I guess it depends on the paranoia level of each person.


My personal experience shows that known good versions of anything may have unknown catastrophic issues so that the only virture which matters is a solid failure management.

If your are sure that 2.7.1 was not prone to file URLs lost on drag and drop operations (something I could not yet reproduce with any version), then the most likely delta is a more up-to-date Qt version in 2.7.2 and on. You could try if legacy-compat (Windows XP compatible) 32 bit builds perform better in this respect. These builds are generated using a very old MXE snapshot with a correspondingly old Qt.

There is also an unknown variable of on-access virus scanners which may interfere with virtually any operation.


I tested v2.7.3 and avidemux_r190331-162845_win64Qt5 (the file from github), both failed in drag and drop using files that failed with v2.7.2. I then installed v2.7.1 that succeeded. I also tried a v2.5.6 that I keep installed for certain operations, that also succeeded in appending the files by drag and drop. So v2.7.2 and v2.7.3 failed, while v2.7.1 and v2.5.6 succeeded. It may not be 100% proof but it does point a very large finger at some change between v2.7.1 and 20th Jan. It's not a critical fault or 'catastrophic'  :) but just an observation.


March 31, 2019, 08:47:22 PM #19 Last Edit: March 31, 2019, 08:50:07 PM by eumagga0x2a
Please test the win32 2.7.2 release. This is needed to attribute the failure straight away to Qt (or not).

edit: 2.7.1 and earlier is synonymous for unknown catastrophic failure :-D


The official 2.7.1 win64 release build (1) uses Qt 5.8.0, the official 2.7.2 win32 one (2) uses Qt 5.7.1 and 2.7.2 win64 (3) as well as my private build Qt 5.12.0.

2 and 3 share +/- the same GUI codebase.


March 31, 2019, 09:40:30 PM #21 Last Edit: March 31, 2019, 09:45:23 PM by fish
I'll give that a go later.

Also here is a test example I tried that failed in v2.7.3 but succeeded in v2.7.1. I would like to hear what results you get using v2.7.3 just in case I have entered the twilight zone without realising. It's just a file that was cut into 4 pieces using v2.7.3.


P.S. I got on very well with v2.7.1 blissfully unaware of any catastrophe.


Drag' and dropping all four fragments works fine on Linux, will reboot to test on Windows 7 64 bit Home.


I'm sorry, but the official 2.7.3 VC++ loads 1.mp4 and appends 2.mp4, 3.mp4 and 4.mp4 per drag-and-drop of a multiple selection from Windows Explorer impeccably on my Windows 7 64 bit Home. I doubt that the detail that you run Avidemux on the Business Edition may matter, so it must be something different what causes the problem.

Can you rule out an on-access virus scanner?


I was half expecting that, I would also not be surprised if I get the same results as you if I repeat the tests tomorrow. It's partly the reason for the long gap between the first post in this thread and revisiting it now. It mostly worked in between then and now, today it doesn't appear to work at all. I'll have another stab at it tomorrow, it not as if append doesn't work at all.


I have tested several versions using the four test files and assuming the problem doesn't originate from between my desk and chair, here  are the results.

v2.7.1 64 bit - drag and drop append and drop down menu append succeeds.

v2.7.2 32 bit - drag and drop append and drop down menu append succeeds

v2.7.3 & v2.7.2 64 bit - drag and drop append fails and drop down menu append succeeds.

Is there a version of v2.7.3 64 bit that doesn't use VC++.  It would be interesting to try that. As no one else is seeing this the obvious solution for me is to use v2.72 32 bit, so it is just curiosity on my part.


Quote from: fish on April 02, 2019, 09:17:38 AM
v2.7.2 32 bit - drag and drop append and drop down menu append succeeds

This points to Qt > 5.8.x then. Still, I can't reproduce the issue, no matter how hard I try.

QuoteIs there a version of v2.7.3 64 bit that doesn't use VC++.  It would be interesting to try that.

This was my private build you tried.


April 02, 2019, 09:35:22 AM #27 Last Edit: April 02, 2019, 10:09:39 AM by fish
Ah, I didn't try that, I will try that again just to be sure.

edit. No, that also failed, I will simply use v2.72 32 bit or the v2.7.3 menu append if I need that function.

Thanks for your help.

edit I forgot to answer your virus scanner query, I use only Windows Defender and run Malwarebytes every month or two.


Just one more query and I'm done with this, the version you uploaded to WeTransfer, was it a patched version or does that still require the patch to be added? You guessed it, I didn't add it nor do I have a clue which folder it should be added to.


It is a patched version (the patch was attached for reference) as I was unsure whether the present two-stage solution to handle drop events might be related to the issue.

Anyway, the topic helped me to understand Avidemux' drag and drop code better, even if we could not identify the nature of the problem as a virus scanner seems to be not involved either.