Author Topic: [Résolu] Sub - Fonts non prise en charge Windows 10  (Read 1760 times)

Apoca

  • Newbie
  • *
  • Posts: 8
[Résolu] Sub - Fonts non prise en charge Windows 10
« on: April 01, 2019, 07:16:37 PM »
Bonjour,

J'étais sur Windows 7 x64 et j'utilisai Avidemux 2.6.11 et les différentes polices d'écriture était reconnu. (tel que Apple Boy BTN / AR Cena / Italianate / Stencil / etc...)

Là, je migre sur Windows 10. et j'utilise (encore) Avidemux 2.6.11 ; mais les polices d'écriture ne sont pas utilisées par le logiciel (font installer dans Windows\fonts).
L'encodage se fait, avec les sous-titres ; mais uniquement avec 1 fonts par défaut. (au lieu < 10).

Testé rapidement sur un autre logiciel "Handbrake", mais lui prend en charge les polices d'écritures.
Et j'ai essayé Avidemux 2.7.0.x et même problème.
Sachant également que pour Avidemux, comme Handbrake , j'ai importé mes "Presets" que j'utilisai.

Étant nouveau sur Windows 10 (x64) et je ne sais pas si c'est normal; s’il y a une manipulation à effectuer ou tout autre.

Je vous remercie par avance de votre aide.

Cordialement.
« Last Edit: April 30, 2019, 05:12:28 PM by Apoca »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3400
Re: Sub - Fonts non prise en charge Windows 10
« Reply #1 on: April 02, 2019, 04:09:29 PM »
Aucune version antérieure à 2.7.2 n'est prise en charge. J'ai essayé la version 2.7.3 sur Windows 10 1809 en utilisant Segoe Print, Consolas, Constantia ainsi q'Arial dans un fichier .ssa et cela fonctionne parfaitment pour moi.

Apoca

  • Newbie
  • *
  • Posts: 8
Re: Sub - Fonts non prise en charge Windows 10
« Reply #2 on: April 02, 2019, 08:24:35 PM »
Salut eumagga0x2a,

Merci de ta réponse,

Je viens de testé rapidement la version 2.7.3, et il semble confirmer la prise en charge des polices d'écritures (autres qu'à défauts)

Par contre, je rencontre 3 petits soucis :
Le 1er : C'est qu'il ne charge /ni visualise les "presets" de configuration d’encodage se trouvant dans :
C:\"Users_Name"\AppData\Roamin\avidemux\PluginSettings\x264          &   \x265
J'ai testé de créer une "preset" ou tout simplement enregistrer celui à défaut. Mais Sauvegarder il le fait, mais il ne le charge /ni le propose; juste "Manuel".

Le 2ème est :
Après le 1er pass, lors d'un encodage en x264 format .avi
J'ai un message :
"Bad Idea" : "Using H264/265 in avi is bas idea, MKV is better for that. Do you want to continue anyway ?"

Y-a-t-il un moyen de désactiver ce message ?
(afin qu'il traite le 2pass automatiquement)

Le 3ème est :
Qu'avant sur la version 2.6.11 j'avais un décalage pour l'incrustation des sous-titres .ass de -19ms ;
En testant rapidement la 2.7.0x, il semblait qu'il n'y avait plus décalage.
et la sur la 2.7.3, il semble aléatoire : Sur la même vidéo sur 2 séquences avec le même sous-titre, le 1er semble etre à -18ms par contre l'autre à -20 /-21 ms.
Rencontrez vous aussi , ce type de décalage ?


Merci d'avance de vos réponses.

Cdt.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3400
Re: Sub - Fonts non prise en charge Windows 10
« Reply #3 on: April 02, 2019, 11:05:05 PM »
Bonsoir,

Le 1er : C'est qu'il ne charge /ni visualise les "presets" de configuration d’encodage se trouvant dans :
C:\"Users_Name"\AppData\Roamin\avidemux\PluginSettings\x264          &   \x265
J'ai testé de créer une "preset" ou tout simplement enregistrer celui à défaut. Mais Sauvegarder il le fait, mais il ne le charge /ni le propose; juste "Manuel".

C'est un problème connu de la version VC++ d'Avidemux. Malheureusement, ce bogue n'a été trouvé qu'après la publication de la version 2.7.3. J'espère bien qu'il sera corrigé bientot. En attendant, veuillez utiliser la version r190310 (c'est 2.7.2 compilée par MinGW comme 2.7.1 et toutes les versions précédentes) à https://avidemux.org/nightly/win64/.

Quote
Le 2ème est :
Après le 1er pass, lors d'un encodage en x264 format .avi
J'ai un message :
"Bad Idea" : "Using H264/265 in avi is bas idea, MKV is better for that. Do you want to continue anyway ?"

Y-a-t-il un moyen de désactiver ce message ?

Non, il n'y a aucun moyen. C'est vraiment une idée extrêmement mauvaise d'utiliser AVI aujourd'hui, particulièrement pour H.264 ou HEVC, parce que ces codecs ont besoin d'horodatages de présentation (PTS) AVI ne prend pas en charge.

Quote
Le 3ème est :
Qu'avant sur la version 2.6.11 j'avais un décalage pour l'incrustation des sous-titres .ass de -19ms ;
En testant rapidement la 2.7.0x, il semblait qu'il n'y avait plus décalage.
et la sur la 2.7.3, il semble aléatoire : Sur la même vidéo sur 2 séquences avec le même sous-titre, le 1er semble etre à -18ms par contre l'autre à -20 /-21 ms.
Rencontrez vous aussi , ce type de décalage ?

~20 ms (milliseconds)? C'est presque rien. Le format de fichier SSA spécifie l'horodatage avec une précision maximale de 10 ms.

Toutefois je reconnais un problème. Les horodatages commencent dans Avidemux à zéro. Si une vidéo contient des images bidirectionnelles (B-frames), Avidemux doit retarder toutes les image afin d'éviter que les horodatages de décodage (DTS) deviennent "négatifs". Les horodatages dans SSA créé avec Aegisub et logiciels comparable ne pas en tiennent en compte.

Sans images bidirectionnelles, la précision doit être absolue.

Apoca

  • Newbie
  • *
  • Posts: 8
Re: Sub - Fonts non prise en charge Windows 10
« Reply #4 on: April 03, 2019, 09:42:21 AM »
testSalut eumagga0x2a,

Merci de ton retour.

C'est un problème connu de la version VC++ d'Avidemux. Malheureusement, ce bogue n'a été trouvé qu'après la publication de la version 2.7.3. J'espère bien qu'il sera corrigé bientot. En attendant, veuillez utiliser la version r190310 (c'est 2.7.2 compilée par MinGW comme 2.7.1 et toutes les versions précédentes) à https://avidemux.org/nightly/win64/.
J'ai effectué des Test :
Avec la version proposé (v.2.7.2 r190310) : j'ai bien les "Presets"pris en charge. Mais plus les polices d'écritures (revient au problème de 2.6.11)
Sachant que j'ai fait l'installation à défaut, sans l'ajout de "vapoursynth" ; comme pour toutes les autres versions.

Et la 2.7.3 lui les prends toujours en charge (les 2 versions installer parallèlement, juste 2 dossier distinct)


Quote
Non, il n'y a aucun moyen. C'est vraiment une idée extrêmement mauvaise d'utiliser AVI aujourd'hui, particulièrement pour H.264 ou HEVC, parce que ces codecs ont besoin d'horodatages de présentation (PTS) AVI ne prend pas en charge.
Le problème c'est que je suis très "old school" est que le format avi m'assure une compatibilité de tous supports pour moi ou mes proches.
De plus, ce format me permet de "splitter" pour graver sur des CD (c'est pour dire  ;) )
Dommage qu'il n'a aucun moyen de supprimer/ désactiver ce message.

Quote
~20 ms (milliseconds)? C'est presque rien. Le format de fichier SSA spécifie l'horodatage avec une précision maximale de 10 ms.

Toutefois je reconnais un problème. Les horodatages commencent dans Avidemux à zéro. Si une vidéo contient des images bidirectionnelles (B-frames), Avidemux doit retarder toutes les image afin d'éviter que les horodatages de décodage (DTS) deviennent "négatifs". Les horodatages dans SSA créé avec Aegisub et logiciels comparable ne pas en tiennent en compte.

Sans images bidirectionnelles, la précision doit être absolue.
J'ai désactiver le B-frame, et oui la synchro s'effectue en test rapide.

Au final reste juste le problème de la prise en charge des polices d'écritures.

Merci d'avance de votre retour.


Cordialement.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3400
Re: Sub - Fonts non prise en charge Windows 10
« Reply #5 on: April 03, 2019, 03:45:22 PM »
Bonjour,

Avec la version proposé (v.2.7.2 r190310) : j'ai bien les "Presets"pris en charge. Mais plus les polices d'écritures (revient au problème de 2.6.11)

C'est très étrange. Toutes les polices d'écritures TTF sont utilisables pour moi avec cette version sur Windows 10 (1809).

Quoi qu'il en soit, la nouvelle version VC++ corrigée (190403) est >> publiée <<.

Quote
De plus, ce format me permet de "splitter" pour graver sur des CD

Non, non, non, pas de tout. Le seul format qui prend en charge le fractionnement de fichier est MPEG-TS. AVI est m...e horrible, ne l'utilise pas, je prie.

Cordialement.

Apoca

  • Newbie
  • *
  • Posts: 8
Re: Sub - Fonts non prise en charge Windows 10
« Reply #6 on: April 03, 2019, 04:24:48 PM »
Salut eumagga0x2a,

Merci encore de tout retour,
et un Grand merci ça fonctionne, en tout cas ça semble ;)

J'espère qu'un jour, le message de "Bad Idea" sera enlever ; afin de gagner du temps sur l'encodage

Quote
De plus, ce format me permet de "splitter" pour graver sur des CD
Non, non, non, pas de tout. Le seul format qui prend en charge le fractionnement de fichier est MPEG-TS. AVI est m...e horrible, ne l'utilise pas, je prie.
Malheureusement ça fait plus d'une décennie que je fonctionne sur du .avi , en splittant ou non , seul le codec utiliser à évoluer mais pour la même finalité, un format SD. (désolé  ;))

Encore un grand merci pour ton aide.

cordialement.

Apoca

  • Newbie
  • *
  • Posts: 8
Re: Sub - Fonts non prise en charge Windows 10
« Reply #7 on: April 07, 2019, 04:21:12 PM »
Bonjour,

Merci encore de ton aide Eumagga0x2a,
ça fonctionnement de façon correcte maintenant sur Windows 10.

Par contre je suis de plus en plus agacé par  le message de confirmation :
"Bad Idea" : "Using H264/265 in avi is bas idea, MKV is better for that. Do you want to continue anyway ?"

il n'y a vrai aucun moyen, de la désactiver; valider auto ; ou autre ?

J'ai essayé de regarde sur le net sans succés :
1 dis que ca se trouve dans : /avidemux_plugins/ADM_muxers/muxerAvi/muxerAvi.cpp
mais pas réussi à trouver.
et un autre proposé un script mais plus une version très ancienne.

Merci d'avance de votre aide :)

cordialement.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3400
Re: Sub - Fonts non prise en charge Windows 10
« Reply #8 on: April 07, 2019, 06:38:04 PM »
Eh bien, l'option de ligne de commande --nogui a été ignorée. Les versions futures d'Avidemux permettront de supprimer (répondre automatiquement par l'affirmative ) tous les dialogues de confirmation --> [automation/qt/cli] Partially fix the silent mode, automatically give affirmative answers to questions

Apoca

  • Newbie
  • *
  • Posts: 8
Re: Sub - Fonts non prise en charge Windows 10
« Reply #9 on: April 10, 2019, 06:48:26 AM »
Salut eumagga0x2a,

Merci de te retour.
Etant neophyte dans script et autres; je ne pas réussi à utiliser ton lien ; malgré les documentations et autres.
Et comme tu la précisais; cette option sera intégré lors d'une prochaine version.

Donc je patienterai. merci encore de ton aide.

Cordialement.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3400
Re: Sub - Fonts non prise en charge Windows 10
« Reply #10 on: April 10, 2019, 05:14:12 PM »
Bonjour,

"une version future" est déjà disponible, c'est "Avidemux_2.7.3 VC++ 64bits 190408.exe" à https://avidemux.org/nightly/vsWin64/. Crée un raccourci vers le fichier avidemux.exe STP et ajoute --nogui à "C:\Program Files\Avidemux 2.7 VC++ 64bits\avidemux.exe" dans les propriétés du raccourci -->

"C:\Program Files\Avidemux 2.7 VC++ 64bits\avidemux.exe --nogui"

Avidemux lancé par ce raccourci n'affichera pas les boîtes des dialogues de confirmation.

Cordialement.

Apoca

  • Newbie
  • *
  • Posts: 8
Re: Sub - Fonts non prise en charge Windows 10
« Reply #11 on: April 11, 2019, 07:36:39 AM »
Salut eumagga0x2a,

Merci de ton retour

Bonjour,

"une version future" est déjà disponible, c'est "Avidemux_2.7.3 VC++ 64bits 190408.exe" à https://avidemux.org/nightly/vsWin64/. Crée un raccourci vers le fichier avidemux.exe STP et ajoute --nogui à "C:\Program Files\Avidemux 2.7 VC++ 64bits\avidemux.exe" dans les propriétés du raccourci -->

"C:\Program Files\Avidemux 2.7 VC++ 64bits\avidemux.exe --nogui"

Avidemux lancé par ce raccourci n'affichera pas les boîtes des dialogues de confirmation.

Cordialement.

C'est nikel, ça fonctionne.
J'ai modifier la commande par contre, pour qu'il soit pris en compte :
"C:\Program Files\Avidemux 2.7 VC++ 64bits\avidemux.exe" --nogui

un grand merci à toi pour tes aides :)

cordialement.
« Last Edit: April 11, 2019, 07:38:41 AM by Apoca »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3400
Re: Sub - Fonts non prise en charge Windows 10
« Reply #12 on: April 11, 2019, 11:16:21 AM »
Merci d'avoir corrigé mon erreur. STP garde à l'esprit que l'option --nogui est un peu dangereuse. Avidemux écrasera les fichiers existants sans avertissement.

Apoca

  • Newbie
  • *
  • Posts: 8
Re: Sub - Fonts non prise en charge Windows 10
« Reply #13 on: April 12, 2019, 11:41:10 AM »
Salut eumagga0x2a,

Merci d'avoir corrigé mon erreur. STP garde à l'esprit que l'option --nogui est un peu dangereuse. Avidemux écrasera les fichiers existants sans avertissement.

Tant qu'il écrase uniquement ces fichiers (de son programs) ça ne sera pas très grave  :D

Merci de l'information.

cdt.
« Last Edit: April 12, 2019, 11:42:44 AM by Apoca »