Non English input controls in edit preferences and Video output configuration

Started by JayMistry, July 01, 2020, 09:54:13 pm

Previous topic - Next topic

JayMistry

I have installed the latest version.
On opening the dialogs for editing preferences and custom video output Cofiguration, I am seeing non English input textboxes and other controls.

My question is, how do I change the NON English (Gujarati) to English text boxes (editors)?

eumagga0x2a

Avidemux uses by default whatever language is the system one. You can force English in the "User Interface" tab of Avidemux Preferences.

If this doesn't help, something has gone wrong on your system regarding fonts. If this case, could you please check whether the problem exists both in MinGW and VC++ builds of Avidemux? MinGW builds use the new Qt 5.15, VC++ builds a much older Qt 5.12.

JayMistry

Thanks for a quick reply

Yes, I have tried both
avidemux_2.7.5 r200626_win64.exe
avidemux_r200626_win64Qt5_22.zip
from
https://avidemux.org/nightly/win64/
but the result is the same.

Is there a way to force that all text inputs will be in the language selected in preferences dialog rather than using system language ?

I am sure this is what a user will expect when changing the language in preferences dialog.

TIA

eumagga0x2a

Quote from: JayMistry on July 02, 2020, 09:53:22 pm
Is there a way to force that all text inputs will be in the language selected in preferences dialog rather than using system language ?


Probably not yet, I need to look into that. Never tried to run Avidemux in a locale with a different script for numerals.

Thank you for your report.

JayMistry


eumagga0x2a

The native digits shown on screenshots seem to be actually Devanagari, but no matter which particular language is really in use, I cannot find a way to make Avidemux or any other application on my admittedly Linux desktop use native numerals instead of default Arabic. Without ability to test, no development is possible. Any help is appreciated.

JayMistry

Thanks again

Let me give you some good news as you do not have to churn your code

I removed all the languages from Control panel Language page and just left the English (United States) and added English (Australia) to keep my regional format settings.

Straight after making this change Avidemux is showing all the digits in English.

What I have learnt from this is that windows can give you unexpected surprises by going away from the language it is coded in.

I appreciate all you help in resolving this issue