Author Topic: AVIDEMUX v2.5.6 will not start  (Read 26243 times)

CeeBeePee

  • Newbie
  • *
  • Posts: 3
AVIDEMUX v2.5.6 will not start
« on: June 19, 2012, 07:57:10 AM »
OS: Windows 7 64 bit
Platform: Intel Quad Core

I have been running AviDemux v2.5.4 successfully until today and then I downloaded the latest stable 64 bit version 2.5.6.  The installation of this version proceeded to completion without error however I could never get the program to start.

I downloaded and tried the 32 bit version with similar results. Ditto latest beta 32/64 (2.6) and all versions of v2.5.5.

Reinstalling the last build of v2.5.4 at least gave me a working copy of AviDemux.

Conclusion: there appears to be a catastrophic problem with AviDemux that started with one of the builds during v2.5.5 which has persisted.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: AVIDEMUX v2.5.6 will not start
« Reply #1 on: June 19, 2012, 08:33:33 AM »
Or there is a catastrophic problem with (your) windows 7?
Other users still seem to be using avidemux 2.5.5 & 2.5.6 and 2.6 beta on windows.
Have you an installed version of zonealarm or similar, this could be causing problems (not allowing avidemux to start)?
You provide to little information to the developers to work with.

CeeBeePee

  • Newbie
  • *
  • Posts: 3
Re: AVIDEMUX v2.5.6 will not start
« Reply #2 on: June 20, 2012, 02:22:16 AM »
Jan, I don't appear to be the only one reporting major problems with AviDemux 2.5.5/2.5.6. Since posting here I have discovered many other quite detailed reports posted on other forums reporting exactly the same problem with exactly the same versions as I reported above.

And, yes, I do have Zone Alarm installed and enabled but I am quite sure that this has nothing to do with this issue as v2.5.4 works just fine when installed under Zone Alarm but not v2.5.5 or v2.5.6 - if I am wrong in this please provide a suggested workaround.

I note your comments about lack of information to enable developers to resolve this issue ... please tell me what further information you need and I will post it promptly!

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: AVIDEMUX v2.5.6 will not start
« Reply #3 on: June 20, 2012, 04:08:20 AM »
Disable zonealarm and uninstall <- link
I'm not a developer. Having zone alarm installed is one of the info you could have provided.

CeeBeePee

  • Newbie
  • *
  • Posts: 3
Re: AVIDEMUX v2.5.6 will not start
« Reply #4 on: June 20, 2012, 11:51:32 PM »
I am not about to uninstall Zone Alarm so that's not an option. It takes too long to setup again after a reinstall. Apart from that, I really don't think Zone Alarm has anything to do with this as I can install and run v2.5.4 without and problems. MeGui and a host of other video software are also able to run without problems just not AviDemux v2.5.5, v2.5.6 and latest Beta. I have check the Zone alarm logs and there is no indication that it is blocking anything from the installation.

gruntster

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 607
    • http://avidemux.razorbyte.com.au
Re: AVIDEMUX v2.5.6 will not start
« Reply #5 on: June 21, 2012, 12:01:42 AM »
ZoneAlarm can definitely cause issues with Avidemux.  I installed ZoneAlarm and Avidemux on a VM and it did indeed prevent Avidemux from starting.  I couldn't easily find a reason why.  Perhaps ZoneAlarm doesn't like executables generated by the newer GCC compilers.

Maybe an owner of ZoneAlarm could contact Check Point and ask for a reason why.

GrapeBu

  • Newbie
  • *
  • Posts: 4
Re: AVIDEMUX v2.5.6 will not start
« Reply #6 on: June 21, 2012, 12:59:47 AM »
I am a newbie.  FWIW,

Avidemux 2.6.0 SVN r8020 (32-bit)
---------------------------------
Built using GCC 4.7.0 and MSVC++ 10.0 SP1.
Packaged with NSIS 2.46.

does not work for me with XP SP3, and AVG anti-virus, no ZoneAlarm.  The GUI window appears for maybe half a second and then exits.  If I start the CLI version in a Command.com, the last few lines before it exits back to the prompt are:

[Script] SpiderMonkey INFO - Spidermonkey initialised
[Win32] Creating audio device
[ADM_jobInit] Initializing database (C:\Documents and Settings\GrapeBu\Application Data\avidemux\jobs.sql)
[ADM_jobCheckVersion] Cannot get version
[ADM_jobInit] Bad database version...
[ADM_jobInitializeDb] Creating database schema...

C:\Program Files\Avidemux 2.6>

I have an .flv file to trim.  A post at a videohelp.com forum suggested that the beta aviDemux might do the trick.

gruntster

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 607
    • http://avidemux.razorbyte.com.au
Re: AVIDEMUX v2.5.6 will not start
« Reply #7 on: June 21, 2012, 01:18:09 AM »
@GrapeBu: Can you try deleting the Avidemux jobs database - C:\Documents and Settings\GrapeBu\Application Data\avidemux\jobs.sql.  Please supply the new output if Avidemux still fails to start.

GrapeBu

  • Newbie
  • *
  • Posts: 4
Re: AVIDEMUX v2.5.6 will not start
« Reply #8 on: June 21, 2012, 03:48:26 AM »
@GrapeBu: Can you try deleting the Avidemux jobs database - C:\Documents and Settings\GrapeBu\Application Data\avidemux\jobs.sql.  Please supply the new output if Avidemux still fails to start.
It creates zero-length files
jobs.sql
jobs.sql-journal        (just for completeness, I also made a run where I deleted this zero-length file too)
as it exits.  No change in behaviour of CLI or GUI.

[Script] SpiderMonkey INFO - Spidermonkey initialised
[Win32] Creating audio device
[ADM_jobInit] Initializing database (C:\Documents and Settings\GrapeBu\Application Data\avidemux\jobs.sql)
[ADM_jobInit] [Jobs] jobs.sql does not exist, creating from default...
[ADM_jobInitializeDb] Creating database schema...

C:\Program Files\Avidemux 2.6>

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: AVIDEMUX v2.5.6 will not start
« Reply #9 on: June 21, 2012, 06:46:09 AM »
ZoneAlarm can definitely cause issues with Avidemux.  I installed ZoneAlarm and Avidemux on a VM and it did indeed prevent Avidemux from starting.  I couldn't easily find a reason why.  Perhaps ZoneAlarm doesn't like executables generated by the newer GCC compilers.

Maybe an owner of ZoneAlarm could contact Check Point and ask for a reason why.

Seen reports that if windows is started in Safe Mode (zonealarm is not running) avidemux would work. I can not test/confirm this. Having no longer access to windows.

Other option, use a second hard disc and use bios to boot either hard disc one or two.
Disconnect hard disc one (windows) and install ubuntu on the 2nd hard disc and install avidemux on it.
After complete installation you can now reconnect the windows hard disc and leave that as drive 0 and ubuntu hard disc as drive one.
Most bios have now a setting where you can enable a boot menu. Every time your computer boots you have now the choice of booting either windows or ubuntu. You could get away with a 150 to 300 GB hard disc for ubuntu.
Use ubuntu for your video projects.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: AVIDEMUX v2.5.6 will not start
« Reply #10 on: June 21, 2012, 06:58:35 AM »
Zonealarm:
  • Exclude trusted files from being scanned
  • Eliminate unnecessary alerts about applications
no guarantee this will work, odd thing is zonealarm is not giving warning?
Quote
To set program control to Auto-learn:
Go to the Program Control panel and move the slider to Auto.
if it is set to MAX

gruntster

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 607
    • http://avidemux.razorbyte.com.au
Re: AVIDEMUX v2.5.6 will not start
« Reply #11 on: June 21, 2012, 07:12:38 AM »
@GrapeBu: It's caused by a bug in 2.6.  I'll try to include a fix for the next build.  There's no workaround.

GrapeBu

  • Newbie
  • *
  • Posts: 4
Re: AVIDEMUX v2.5.6 will not start
« Reply #12 on: June 21, 2012, 05:52:09 PM »
@GrapeBu: It's caused by a bug in 2.6.  I'll try to include a fix for the next build.  There's no workaround.
Thanks for the quick response.  In the docs I didn't find any claim that avidemux (2.6 beta for instance) works for any particular version of Windows, so I guess there's no list where XP needs to be crossed off. 

It might be related to this:
http://www.avidemux.org/smf/index.php?topic=10513.msg56923#msg56923
where other versions do not work with XP SP3.
« Last Edit: June 21, 2012, 05:58:50 PM by GrapeBu »

gruntster

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 607
    • http://avidemux.razorbyte.com.au
Re: AVIDEMUX v2.5.6 will not start
« Reply #13 on: June 21, 2012, 10:08:04 PM »
It's an issue with SQLite, which is only used by 2.6.  Windows Vista and 7 are also affected.

2.5 issues will be caused by something else, most likely ZoneAlarm.

gruntster

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 607
    • http://avidemux.razorbyte.com.au
Re: AVIDEMUX v2.5.6 will not start
« Reply #14 on: June 25, 2012, 11:50:00 AM »
r8027 or later should fix Avidemux 2.6 failing to start on 32-bit Windows.