February 27, 2021, 09:19:54 PM



"Too Short" error trying to save TS files in copy mode

Started by Ronstang, November 04, 2020, 10:36:42 PM

Previous topic - Next topic


I have the latest version installed the other day all of a sudden I cannot save any TS files that I edit.  Every one results in the following error immediately upon hitting the save button:

Too Short

The saved video is incomplete. The error occured at 00.00.00,233 (0), This may happen as result of invalid time stamps in the video.

I have tried multiple files and all result in the error but if I open any of the files over my network on my other machine without even re-indexing them I can edit and save them with no problem.  I tried re-installing Avidemux and the results are the same so the problem is related to this machine only.

I use this program every day and now I am bottlenecked because I have not been able to use it easily in days so I need to solve this problem as I record a lot of TV that I edit with Avidemux.

Thank you


Do you mean the last release (2.7.6) or the latest nightly (recommended) as "the latest version"? Can you rule out that you mixed a VC++ build with a MinGW one in one and the same directory? Have you tried to move Avidemux profile directory (%appdata%\avidemux), thus resetting the configuration?

If you can answer the last two questions with "yes" and if the problem persists with the latest nightly, please remove *.idx2 files, load a MPEG-TS file, reproduce the issue, close Avidemux, then attach admlog.txt from %localappdata%\avidemux\ to your reply to allow to assess the situation.


I installed the latest nightly build of 2.7.7.  Complete install removing everything else.  The issue persisted so I moved the log file like you said to reset the configuration and tried again.  I still get the same error.  The log is below:

You cannot see attachments on this board.

Thank you.


Thank you, this is the relevant part:

[FF]Error writing video packet
[saveLoop] 01:13:26-153 [FF] Wrote 11 frames, nb audio streams 1
[saveLoop] 01:13:26-153 [FF] Found 0 missing PTS / 11 total frames
[ffTS] Closing
[closeMuxer] 01:13:26-153 Error -28 writing trailer.

Unfortunately, Avidemux doesn't log the output path and filename. Seeing an error from flushing the output stream to disk makes me think something might be wrong here. Does saving fail regardless of the target location? Does it fail if you choose an output filename without spaces and special characters in a folder where you have write permissions and enough disk space on a local drive?


I'm sorry, this appears to be a user error....me, I'm not paying attention lately.  I thought I had changed the path to the new 4 TB drive I installed but it somehow reverted to the old save location I used that is out of space. Sorry for bothering you but I have learned about the nightly builds and this is one of my favorite programs so that is a positive.

Thanks and sorry,